Symptoms
1. You use a MassTransit web-client and a proxy server to connect to the Internet.
2. You can download files only from outside your network. There is an error-message «Failed to connect, but connection method did not report a reason for failure» internally.
Cause
The MassTransit Web Assistant Plug-in was not designed to work in conjunction with a proxy.
Solution
You will need to disable the proxy settings or switch to HTTP mode before attempting to transfer any files. Note that with HTTP mode you cannot transfer files larger than 2 GBs.
More information