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Acronis Backup Advanced 11.5: Updating Acronis Management Server Fails with "The file is compressed but does not reside in a read-only database or filegroup."

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Decompress files listed in the error message.

This article applies to:

  • Acronis Backup Advanced 11.5

Symptoms

  1. You're updating Acronis Management Server to a new build.
  2. Update fails with:

LineInfo: 0x39098ee09af00d2b
Message: An error occurs while executing SQL command: USE acronis_cms_stats
------------------
Error code: 08323089
LineInfo: 0xc131f5921ff77449
Message: Query 'USE acronis_cms_stats' failed to execute.
------------------
Error code: 08324017
LineInfo: 0xc131f5921ff77428
Message: Database 'acronis_cms_stats' cannot be opened due to inaccessible files or insufficient memory or disk space.  See the SQL Server errorlog for details.
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Error code: 08328183
LineInfo: 0xc131f5921ff77428
Message: File activation failure. The physical file name "C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\acronis_cms_stats_log.ldf" may be incorrect.
------------------
Error code: 08328190
LineInfo: 0xc131f5921ff77428
Message: The file "C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\acronis_cms_stats_log.ldf" is compressed but does not reside in a read-only database or filegroup. The file must be decompressed.

Cause

AMS databases are compressed and cannot be accessed during update.

Solution

Turn off the file compression for the SQL database files specified in the error message:

  1. Navigate to C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\acronis_cms_stats_log.ldf
  2. Right-click on the file.
  3. Under Attributes select Advanced.
  4. Uncheck Compress contents to secure data.
  5. Perform update.

Segments:


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