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Acronis vmProtect: Failback from Replica Fails

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This article applies to:

  • Acronis vmProtect

Introduction

The article describes the troubleshooting steps to investigate the problem when the Failback operation fails.

Solution

Follow these steps to troubleshoot the issues when Failback operation fails:

  1. Get familiar with technology of Failback operation in the About part.
  2. Follow to Troubleshooting part to troubleshoot and resolve the issue.


 

 

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Acronis Backup & Recovery: Troubleshooting Deduplication Backup Failures

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This article applies to:

  • Acronis Backup & Recovery

Introduction

This article provides information on troubleshooting possible failures during Deduplication.

Solution

Deduplication is a complex process involving many operations and components and thus has a number of possible points of failure. In order to properly troubleshoot and resolve such issues, the first step is to find the exact point of failure. Once this clear, we have to collect the proper diagnostic information. Please follow the guide below in order to do this.

Select the situation that applies:

 

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Acronis Backup & Recovery: Troubleshooting Tape Read/Write Errors

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Instructions on how to troubleshoot and resolve issues with tape devices.

This article applies to:

  • Acronis Backup & Recovery

Introduction

When backing up to a magnetic tape media, you may encounter issues with device detection or read/write operations. This article provides instructions on how to troubleshoot and resolve such issues.

Solution

Follow these steps to troubleshoot issues with backing up to magnetic tape media:

  1. Get familiar with technology of devices and tapes in the About part.
  2. Check for known issues in the Known issues part.
  3. Follow the Troubleshooting part to troubleshoot and resolve the issue.

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Acronis SharePoint Explorer: Installation Prerequisites

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This article describes what is needed for successfull installation of Acronis SharePoint Explorer

This article applies to:

  • Acronis Backup & Recovery 11.5 Server fow Windows with Microsoft SharePoint
  • Acronis Backup & Recovery 11.5 Advanced Server for Windows with Micrososft SharePoint
  • Acronis Backup & Recovery 11.5 for Microsoft SharePoint Add-on

Description

Check if following conditions are met:

One of the supported versions of MS SharePoint installed:

Microsoft Windows SharePoint Services 3.0 SP2*
Microsoft Office SharePoint Server 2007 SP2*
Microsoft SharePoint Foundation 2010 SP1
Microsoft SharePoint Server 2010 SP1
Microsoft SharePoint 2013

2. Agent must be installed on machine with MS SharePoint: 

2.1 The agent must be installed on a machine running 64-bit Windows and Microsoft SharePoint Front-end Server

2.1 If you use Microsoft Windows SharePoint Services 3.0 or Microsoft Office SharePoint Server 2007, install the agent on a SharePoint recovery farm. 

3. Console can be installed on any machine running MS Windows XP x86/x64 or later with MS .NET Framework installed.

Best practice is to install console to the machine with MS SQL server installed which is used to attach databases to instances.

4. To extract data from single-pass backups, you also need Acronis Backup & Recovery Agent for Microsoft SQL Server (single-pass) and Acronis Backup & Recovery Command-Line Tool on the same machine with the console. These components can be installed using Acronis Backup and Recovery components installation pack.

More information

MS .NET Framework is installed automatically during console installation, if machine has active internet connection. In other cases .NET Framework can be downloaded manually from Microsoft web-site on another machine 

 

 

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Acronis vmProtect: File Recovery Fails

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This article applies to:

  • Acronis vmProtect

Introduction

This article describes the steps that can help to investigate problems when file recovery operaiton fails.

Solution

Follow these steps to troubleshoot the issues when the recovered data is corrupted:

  1. Get familiar with technology of backup and recovery of virtual machines in the About part.
  2. Check for known issues in the Known issues part.
  3. Follow to Troubleshooting part to troubleshoot and resolve the issue.

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Acronis vmProtect: Troubleshooting Application Malfunction after Recovery

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This article applies to:

  • Acronis vmProtect

Introduction

This article describes the steps to investigate the problem if any application failure after the VM recovery

Solution

Follow these steps to troubleshoot the problem with applications failure after the VM restore operation:

  1. Get familiar with technology of VM backup and recovery in the About part.
  2. Follow to Troubleshooting part to troubleshoot and resolve the issue.


 

 

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Acronis vmProtect: Troubleshooting VM Recovery Failures

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This article applies to:

  • Acronis vmProtect

Introduction

This article provides instructions on how to investigate issues when the VM restore operation fails.

Solution

Follow these steps to troubleshoot the issues when the VM recovery operation fails:

  1. Get familiar with technology of Recovery operation in the About part.
  2. Follow to Troubleshooting part to troubleshoot and resolve the issue.

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Acronis Backup & Recovery: Scheduled Backup Plan Issues Caused by Antivirus Software

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Exclude Acronis program folders, executable files and program data from the antivirus check.

This article applies to:

  • Acronis Backup & Recovery
  • Windows

Symptoms

Each Acronis backup plan consists of one or more tasks: backup task, replication task, conversion task, validation task etc. If you start any action from the plan manually (button 'Run') you will be able to see which tasks are available in the specified plan.

After installing any version of Acronis Backup & Recovery and configuring scheduled packup plan you may observe any of the following issues:

  • tasks disappear after a while;
  • scheduled tasks do not run at all;
  • some or all options are missing in the backup plan when trying to select them manually;
  • there are doubled tasks if you try to choose an option manually in the backup plan.

Cause

After configuring backup plans on Acronis Management Server (AMS) or local machine with Acronis agent (MMS) each Acronis task is saved as xml file on the agent and centralized plans are saved in db3 sqlite database on the AMS in the following locations:

  • AMS:

Windows Vista, 7, 8, 8.1, Server 2008, 2012: \ProgramData\\Acronis\AMS\dml_objects.db3

Windows XP, 2003: \Documents and Settings\All Users\Application Data\Acronis\AMS\dml_objects.db3

  • MMS: .xml files in

Windows Vista, 7, 8, 8.1, Server 2008, 2012: \ProgramData\Acronis\BackupAndRecovery\MMS\TaskStorage

Windows XP, 2003: \Documents and Settings\All Users\Application Data\Acronis\BackupAndRecovery\MMS\TasksStorage

If these xml files become corrupt or missing, information about tasks can be shown incorrectly or tasks dissappear from Acronis GUI.

In the most cases xml files are being deleted or modified by antivirus software if Acronis files and executables are not excluded from the antivirus check.

 

Solution

Exclude Acronis program folders, executable files and program data as described in this article: Exclude Program Folders and Executables from Security Programs.

After excluding Acronis data from antivirus check recreate existing backup plans. This way all tasks should become available again.

If the AMS database got corrupt it should be investigated separately.

 

More information

If the above solution does not help or the issue differs from the described one please collect System Report from AMS and MMS agent, exported backup plan and Process Monitor Log gathered at the scheduled task start and contact Acronis Support.

Currently it is not possible to prevent file deletion or corruption caused by antivirus software. In the next versions of Acronis Backup & Recovery structure of backup plans and taks will be changed, which should prevent task deletion by antivirus software.

 

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Acronis Software: Troubleshooting Application Lockups

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Instructions on how to troubleshoot application lockups.

This article applies to:

  • Acronis Backup & Recovery
  • Acronis vmProtect
  • Acronis Snap Deploy
  • Acronis True Image

Follow these steps to troubleshoot application lockups:

  1. Learn how to spot an application lockup in the About part.
  2. Follow to Troubleshooting part to collect the information necessary for troubleshooting.


More information

With information collected please contact Acronis Customer Central.

 

Using GDB to Create Memory Dumps of Processes Running on Acronis Virtual Appliance or Acronis Linux-based Bootable Media

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Files / Downloads: 

This Article describes how to collect dumps of hanging processes on a Virtual Appliance or a linux-based Bootable media. You will need a machine to remotely connect to the bootable media.

This Article applies to:

  • Acronis Software

Description

This Article describes how to collect dumps of hanging processes on a Virtual Appliance or a linux-based Bootable media. You will need a machine to remotely connect to the bootable media.

  1. Download gdb.zip attached to this article.
  2. Extract it.
  3. Download WinSCP. Download Putty.
  4. Boot into the non-quiet mode:
  • Bootable Media: on the Boot Selection screen click F11. Delete "quiet" from the textbox.
  • Virtual Appliance: when you see choise of kernels during the boot-up click "e" and delete "quiet".
  • Start ssh daemon issuing the command "/bin/sshd". If you see any error just click "Enter".
  • Start the product issuing the command "/bin/product".
  • Check the IP of the bootable media. If there is no IP - your NIC might not be detected. Try a newer version of the bootable media, for more information see Acronis Bootable Media: Troubleshooting NIC Detection
  • Use WinSCP to connect to the IP that you've checked above. Login, password is "root","root". Connection type "SCP".
  • Transfer files using WinSCP: gdb itself to the root folder ("/"), lib files to the /lib/ folder.
  • Use Putty to connect to the above IP using the same username and password. 
  • Make gdb executable and accessible issuing commands in Putty "chmod 0777 /gdb" and "chmod +x /gdb"
  • Check the PID (Process ID) of the hanging process: 
    • Bootable media: usually the process in question is /bin/product. The command to check would be "ps ax | grep /bin/product"
    • Virtual Appliance: if the GUI and agent itself hangs it is the same as on bootable media. However if the backup/replication/cleanup/recovery hangs in Acronis Backup & Recovery Virtual Appliance, the process name is service_process. For vmProtect processes see Acronis vmProtect 9: Processes and Services. The command would be "ps ax | grep service_process". If you see more that 1 service process running you will have to create a dump of each.
  • Switch to GDB shell with the following command: #gdb -pid <process_id> where <process_id> is the identificator of the hanging process.
  • Use command #gcore to write a core file.
  • Detach the core file with #detach
  • Repeat these steps several times to get more dumps. Quit GDB with #quit
  • Dumps will be generated in the root folder "/". They will look like "core.<PID>"
  • Use WinSCP to download them.
  • Zip the dumps and contact Acronis Customer Central with reference to this article.
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    Acronis vmProtect 9: Processes and Services

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    List of Acronis vmProtect 9 services and processes

    This article applies to:

    • Acronis vmProtect 9

    Description

    Acronis vmProtect 9 processes:

    Process namePurpose
    agent.exeCore component used to coordinate interaction between Acronis components, allows connections from vmms.exe to local system services
    vmms.exeExecutes main operations: backup, restore, validation, etc
    vmprotectservice.exeProcesses backup/replication tasks
    wcs.exeInteraction between the web console and vmms.exe
    lighttpd.exeAllows connections to the web console via browser
    schedul2.exeResponsible for tasks execution on schedule
    schedhlp.exeMonitors Schedule2 service and restarts it if needed
    nfs_server.exeProvides NFS server used to mount VMs
    portmap.exeProvides coordination between RPC services and respective port numbers
    mediabuilder.exeBuilds Acronis Bootable Rescue Media

     

    Acronis vmProtect 9 Windows services (if Windows Agent is installed):

    Service namePurpose
    Acronis vmProtect Managed Machine ServiceExecutes main functionality
    Acronis vmProtect Web Console ServiceOperations with the Web Console
    Acronis Remote Agent ServiceCommunication between vmProtect components
    Acronis Scheduler2 ServiceExecuting scheduled backups
    Acronis LightTPDConnection to the Web Console via browser
    Acronis NFS ServerNFS server used for mounting VMs

     

    More information

    See also Acronis vmProtect 9

     

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    Acronis vmProtect: Troubleshooting Slow Backup

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    This article applies to:

    • Acronis vmProtect

    Introduction

    The article describes the troubleshooting steps to investigate slow backup issues.

    Solution

    Follow these steps to troubleshoot the issues with slow backup creation speed:

    1. Get familiar with technology of VM Backup Creation in the About part.
    2. Check for known issues in the Known issues part.
    3. Follow to Troubleshooting part to troubleshoot and resolve the issue.


     

     

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    Acronis vmProtect: Troubleshooting Slow Replication

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    This article applies to:

    • Acronis vmProtect

    Introduction

    The article describes troubleshooting steps to investigate slow replication issues.

    Solution

    Follow these steps to troubleshoot the issues with slow replication:

    1. Get familiar with the Replication technology in the About part.
    2. Check for known issues in the Known issues part.
    3. Follow to Troubleshooting part to troubleshoot and resolve the issue.


     

     

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    Acronis Snap Deploy 4: Processes and Services

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    List of Acronis Snap Deploy 4 services and processes

    This article applies to:

    • Acronis Snap Deploy 4

    Description

    Acronis Snap Deploy processes:

    Process namePurpose
    SnapDeployConsole.exeOperates the Management Console (GUI)
    schedul2.exeExecutes scheduled deployments
    schedhlp.exeMonitors Schedul2 service and restarts it if needed
    agent.exeEnables main functionality
    ImageCreatorService.exeCreates master images
    MediaBuilder.exeCreates bootable media
    fileserver.exeAcronis files/images download service
    pxesrv.exeAcronis PXE Server service
    LicenseServerConsole.exeAn additional license management tool
    LicenseServerCmdLine.exeCommand line tool for license management
    ds_invoker.exeLaunches deployment tasks for execution
    DeployPEBuilder.exeWindows PE Builder that can be run from Tool -> Create PE image
    cdrecord2.exeAcronis component that is used for burning an image or Bootable media on CD/DVD
    acroinst.exeAcronis remote install utility. This utility is run on a target machine during remote installation.
    msi_setup.exeAcronis MSI Setup Utility. This utility is run on a target machine during remote installation.

     

    Acronis Snap Deploy 4 services:

    Service namePurpose
    Acronis File Server ServiceAcronis files/images download service
    Acronis PXE Server ServiceEnables network booting into a rescue environment over the subnet
    Acronis Remote Agent ServiceEnables connectivity among Acronis components
    Acronis Scheduler2 ServiceProvides scheduling for Acronis components' tasks

     

    More information

    See also Acronis Snap Deploy 4

     

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    Acronis vmProtect: Troubleshooting Slow Validation

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    This article applies to:

    • Acronis vmProtect

    Introduction

    The articles describes steps to troubleshoot issues with slow validation.

    Solution

    Follow these steps to troubleshoot the issues when the validation backup speed is slow:

    1. Get familiar with technology of Archive Validation in the About part.
    2. Go to Troubleshooting part to troubleshoot and resolve issues.


     

     

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    Acronis Backup & Recovery for Hyper-V: Virtual Machines are Unavailable during Snapshot Creation

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    Deactivate scoped snapshots for Hyper-V virtual machines.

    This article applies to:

    • Acronis Backup & Recovery 11.5 for Hyper-V
    • Windows Server 2012

    Symptoms

    1. You create an agentless (with Agent for Hyper-V on the host) backup of a virtual machine.
    2. Backup is performed offline (for more information see Microsoft Technet: Understanding online and offline backups). As a result, after backup start the virtual machine is not available for several minutes as it turns into Saved State.
    3. Backup runs and finishes successfully.
    4.  You can see the following error message in the Windows Application Event Log of the virutal machine:

    Event ID: 13
    Description: Windows cannot perform an online backup of this system because scoped snapshots are enabled. To resolve this, disable scoped snapshots by creating the following registry value on this computer:
    PATH: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\
    DWORD: ScopeSnapshots
    Value: 0
    Incorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data on the computer.

    Cause

    VSS Snapshots in the guest OS are set to use scope snapshots. As a result, only particular files are included into Copy on Write (Shadow) snapshot, and not all the volume files. Scope snapshot are mainly used by Windows critical updates.

    Solution

    Following the instructions in the error message, deactivate scoped snapshots:

    1. Open Windows Registry: Start -> Run -> regedit.exe
    2. Create a DWORD ScopeSnapshots parameter with Value "0" in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\

    More information

    Please contact Acronis Customer Central if you need assistance.

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    Acronis Backup & Recovery 11.5: Creating or Opening Managed Vault Fails with "There is not enough space on the disk"

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    Fee up space on the volume where the system temp folder resides or point it to another volume.

    This article applies to:

    • Acronis Backup & Recovery 11.5

    Symptoms

      1. You want to create a new centralized managed vault or to open an existing one.
      2. Operation fails with error "Operating system directive CreateFileMapping failed; There is not enough space on the disk."


    Cause

    Volume where the system temp folder resides is full.

    Solution

    Free up space on the volume with the system temp folder:

    1. Check where it resides: right-click on Computer -> Properties -> Advanced system settings -> Environment Variables and note paths for TEMP and TMP;
    2. Free up space on the volume where these folders reside or point the variables to another volume with sufficient free space.

    More information

    Please contact Acronis Customer Central if you need assistance.

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    Acronis vmProtect: Troubleshooting Active Directory Malfunction in Replica VM

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    This article describes how to troubleshoot issues related to AD malfunction after the replication of VM while using vmProtect.

    This article applies to:

    • vmProtect 9
    • vmProtect 8
    • vmProtect (earlier versions)

    Introduction

    The replication feature provides you with the ability to clone the critical VMs and to be able to start this service fast in case of failure.

    Solution

    Follow these steps to troubleshoot AD malfunction after the replication of VM:

    1. Get familiar with technology of VM replication in the About part.
    2. Check for known issues in the Known issues part.
    3. Follow to Troubleshooting part to troubleshoot and resolve the issue.


    More information

    Acronis vmProtect 8 online documentation

    Acronis vmProtect 9 online documentation

     

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    Acronis vmProtect: Troubleshooting Application Malfunction in Replica VM

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    This article describes how to troubleshoot issues related to Application malfunction in Replica VM while using vmProtect.

    This article applies to:

    • vmProtect 9
    • vmProtect 8
    • vmProtect (earlier versions)

    Introduction

    The replication feature provides you with the ability to clone critical VMs and to be able to start this service fast in case of failure.

    Solution

    Follow these steps to troubleshoot Application malfunction in Replica VM after the replication of VM:

    1. Get familiar with technology of VM replication in the About part.
    2. Check for known issues in the Known issues part.
    3. Follow to Troubleshooting part to troubleshoot and resolve the issue.


    More information

    Acronis vmProtect 8 online documentation

    Acronis vmProtect 9 online documentation

     

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    Acronis SharePoint Explorer: Troubleshooting Database Detection Issues

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    This article describes what to check when unable to detect database in previously created backup.

    This article applies to:

    • Acronis Backup & Recovery 11.5 Server for Windows with Microsoft SharePoint
    • Acronis Backup & Recovery 11.5 Advanced Server for Windows with Microsoft SharePoint
    • Acronis Backup & Recovery 11.5 for Microsoft SharePoint Add-on
    • Acronis SharePoint Explorer

    Introduction:

    Microsoft SharePoint stores sites and applications data in SQL databases, so, issues with SharePoint database detection are closely connected to SQL database detection.

    What to check first:

    1. Try to browse SharePoint database that resides in archive using Acronis Backup and Recovery console. If database is not there, then check if archive was created using Single-Pass option.
    2. Check that operating system and SQL version are supported. Use this article: Acronis Backup & Recovery 11.5 for Microsoft SQL Server: Requirements for Single-Pass Backup
    3. Check if Acronis SharePoint Explorer installation prerequisites are present. Use this article: Acronis SharePoint Explorer: Installation Prerequisites

    Proceed to collecting info step, if all statements above are true.

    Collecting information:

    In case none of the above was helpfull, collect following information and escalate the case:

    1. Collect a Process Monitor Log when selecting the source, see Collecting Process Monitor Log
    2. Logs of server where console is installed. (C:\ProgramData\Acronis\ASPDE\Logs)
    3. Error message  
    4. Collect System Report from the machine in question: see instruction for Acronis Backup & Recovery 11.5 Generating System Report, if this fails for any reason, you can use this AcronisInfo Utility
    5. PCAP log if archive or SQL database reside on remote machine, see Collecting PCAP Logs

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